Technical Requirements

The website that hosts our online education program is https://yale.instructure.com and the platform is called "Canvas."

The live videoconferences with guest experts will occur using an Adobe Connect Platform. You can test your connectivity to Adobe Connect using this link below. If you encounter any problems, please take a screen-shot of the problem and send it to the course assistant. https://na1cps.adobeconnect.com/common/help/en/support/meeting_test.htm (Links to an external site.)

Equipment
Canvas is designed to work on computers with 1GB of RAM and a 2GHz processor. The website will run on Windows, Mac, Linux, iOS, Android, or any other device with a modern web browser. Preferred operating systems are:
  • Windows XP SP3 and newer
  • Mac OS X 10.6 and newer
  • Linux chromeOS
With respect to internet speed, Canvas has been carefully crafted to accommodate low bandwidth environments. The minimum for optimal functioning is 512kbps.

To use the Adobe Connect feature, you may not need additional equipment if you plan to view/listen to the presentation and write any questions in the chat feature. However, if your connection is strong enough, we welcome you to additionally use a web camera and headphones with a microphone to ask questions and participate in the discussions. It is preferable that you use a headset with a microphone instead of using the computer’s built-in microphone. However, if you plan to use the built-in microphone, it is very important that you use headphones for listening. This is because the sound coming out of the computer speakers can go back into the computer microphone, creating loud and unpleasant feedback for the rest of the participants. 

Software
Canvas supports the last two versions of every browser release. We highly recommend updating to the newest version of whatever browser you are using as well as the most up-to-date Flash plug-in. As of August 19, 2013, we support the following desktop browsers and Flash versions:
  • Internet Explorer 9 and 10
  • Chrome 26, 27, and 28
  • Safari 5 and 6
  • Firefox 21, 22, and 23
  • Flash  9, 10, and 11 (if you want to use the audio/video recording or viewing feature or upload files)
Some supported browsers may still produce a banner stating "Your browser does not meet the minimum requirements for Canvas." If you have upgraded your browser but you are still seeing the warning banner, try logging out of Canvas and deleting your browser cookies.

Most of the tools in the course will take place within the same window. However, just to be sure, please ensure that your browser settings allow popups.

Adobe Flash is required in several places in Canvas: media streaming, interactive presentations, and viewing as well as uploading files for an assignment. (http://get.adobe.com/flashplayer/)

The Java plug-in may also be required. (http://www.java.com) (Links to an external site.)
Share this page: